通达信三死叉,日线死叉

内容导航:
  • 老师,可以把通达信股票公式 天一神鞭发给我吗?谢谢!
  • 求高手编写通达信三死叉预警选股公式。
  • 三线金叉买入法是什么?
  • 三金叉和三死叉的图是怎样的
  • Q1:老师,可以把通达信股票公式 天一神鞭发给我吗?谢谢!

    动态止损度:=5;
    黑:=0;{下跌通道黑色K线开关}
    离L:=0;{乖离提示开关}
    提示:=0;{买卖文字提示开关}
    布林M:=0;{开关}
    MMA:=0;
    五:MA(CLOSE,5),COLORWHITE;
    十:MA(CLOSE,10),COLOR00FFFF;
    M18:=MA(CLOSE,18),COLORRED;
    离基:=五;
    离O:=离基*1.20,COLOR555555;
    离A:离基*1.15,COLOR555555;
    离B:离基*1.10,COLOR555555;
    离C:离基*0.90,COLOR555555;
    离D:=离基*0.85,COLOR333333;
    EXP50:=EXPMA(CLOSE,50),COLORGREEN;
    MA30:MA(CLOSE,30),LINICK1,COLORRED;
    MA60:MA(CLOSE,60),COLORGREEN;
    β0:=(H-L)/2+L,LINICK0;
    α:=β0,LINICK0;
    β:=REF(β0,1),LINICK0,COLORGREEN;
    γ:=REF(β0,2),LINICK0,COLORMAGENTA;
    {涨:PLOYLINE(C>REF(C,1),CONST(C)),COLOR0000AA,LINICK1;
    跌:PLOYLINE(C<REF(C,1),CONST(C)),COLOR00AA00,LINICK1;}
    高:PLOYLINE(1,CONST(HHV(H,50))),COLOR770077,LINICK1;
    低:=PLOYLINE(1,CONST(LLV(L,50))),COLOR777700,LINICK1;
    中:=PLOYLINE(1,(高-低)/2+低),COLOR005555,LINICK4;
    止损价:=CONST(HHV(C,5)*(100-动态止损度)/100);
    止:PLOYLINE(CONST(C)<=止损价,止损价),COLOR888800,LINICK4;
    DRAWTEXT(DYNAINFO(7)<=止损价 AND ISLASTBAR,止损价*1.05,'止损');
    AA:=CLOSE/REF(C,1)>=1.09;
    BA:=CLOSE/REF(C,1)>=1.09;
    DRAWKLINE(H,O,L,C);
    STICKLINE(AA,O,C,2.5,1),COLORYELLOW;
    MA1:=MA(CLOSE,5),COLORRED;
    MA2:=MA(CLOSE,10),COLORYELLOW;
    MA3:=MA(CLOSE,20),COLOR770077;
    E50:=EXPMA(CLOSE,50),LINICK1,POINTDOT,COLORLIGREEN;
    E100:=EXPMA(CLOSE,100),POINTDOT,COLORGRAY;
    MA181:MA(C,181),COLORGRAY;
    {MA60:=MA(C,60),COLOR007700;}
    {周:IF( MMA=1 ,MA2,DRAWNULL),COLORYELLOW,LINICK1;
    月:IF( MMA=1 ,MA3,DRAWNULL),COLORWHITE,LINICK1;
    季:IF( MMA=1 ,MA4,DRAWNULL),COLORGREEN,LINICK1;}
    {IF(C>E50 ,E50,DRAWNULL),COLOR00FF00,LINICK1;}
    IF(CONST(α>β) AND DYNAINFO(7)>0,DYNAINFO(7),DRAWNULL),COLOR000088,LINICK1;
    IF(CONST(α<=β)AND DYNAINFO(7)>0 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINICK1;
    IF(CONST(α>β) AND DYNAINFO(7)>0 AND DYNAINFO(7)>=高*0.99,DYNAINFO(7),DRAWNULL),COLOR000088,LINICK1;
    IF(CONST(α<=β)AND DYNAINFO(7)>0 AND DYNAINFO(7)<=低*1.01 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINICK1;
    N1:=12;
    N2:=26;
    N3:=9;
    DIFF:=(EMA(CLOSE,N1) - EMA(CLOSE,N2));
    DEA:=EMA(DIFF,N3);
    MACD:=(2 * (DIFF - DEA));
    MACD2:=MACD;
    SARH:=CLOSE>SAR(4,2,20);
    {IF(C<MA3 ,MA1,DRAWNULL),COLOR555555,LINICK1;}
    {IF(C<MA3 ,MA2,DRAWNULL),COLOR222222,LINICK1;}
    {IF(五>=REF(五,1) ,离A,DRAWNULL),COLOR0000FF,LINICK1;
    IF(五>=REF(五,1) ,离B,DRAWNULL),COLOR0000FF,LINICK1;
    IF(五<=REF(五,1) ,离C,DRAWNULL),COLOR00FF00,LINICK1;
    IF(五<=REF(五,1) ,离D,DRAWNULL),COLOR00FF00,LINICK1;}
    五V:=MA(V,5);
    {IF(五V>=REF(五V,1) ,离A,DRAWNULL),COLOR0000FF,LINICK1;
    IF(五V>=REF(五V,1) ,离B,DRAWNULL),COLOR0000FF,LINICK1;
    IF(五V<=REF(五V,1) ,离C,DRAWNULL),COLOR00FF00,LINICK1;
    IF(五V<=REF(五V,1) ,离D,DRAWNULL),COLOR00FF00,LINICK1;}
    {IF(五<REF(五,2) AND 离L=0,离A,DRAWNULL),COLOR555555,LINICK1;
    IF(五<REF(五,2) AND 离L=0,离D,DRAWNULL),COLOR555555,LINICK1;}
    TYP:=(HIGH+LOW+CLOSE)/3;
    CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
    STICKLINE(C<MA3 AND 黑=1,H,L,0,0),COLOR555555;
    STICKLINE(MA1<MA3 AND 黑=1,O,C,2.5,1),COLOR555555;
    STICKLINE(BA AND C<MA3,O,C,2.7,1),COLORWHITE;
    {DRAWICON(MACD>REF(MACD,1) AND CROSS(C,MA3) AND 提示=0 ,L,1);}
    {DRAWICON(REF(C>MA3 AND 提示,1) AND CROSS(MA(C,5),C),H,2);}
    N:=14;
    M:=6;
    HD :=HIGH-REF(HIGH,1);
    LD :=REF(LOW,1)-LOW;
    DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
    DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
    PDI:=DMP*100/TR;
    MDI:=DMM*100/TR;
    ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
    ADXR:=EXPMEMA(ADX,M);
    DMIJX:=CROSS(PDI,MDI) AND C>O ;
    {STICKLINE(DMIJX,H,L,0,1),COLORYELLOW;
    STICKLINE(DMIJX,O,C,2.7,0),COLORYELLOW;}
    {DRAWICON(DMIJX AND 提示=0,L,1);}
    {DRAWTEXT(H>离A,离A/0.99,'★'),COLORYELLOW;}
    头上边:=MAX(O,C),NODRAW;
    头下边:=MIN(O,C),NODRAW;
    垂头:=ABS(O-C),NODRAW;{垂头}
    长针:=(头下边-L),NODRAW;{长针}
    垂:=长针/垂头>2 AND (H-头上边)<=长针 AND L<REF(L,1) AND O<REF(C,1),NODRAW;
    DRAWTEXT(垂 AND L<=LLV(L,3) AND L<离C AND 提示,L/1.01,'针') AND 提示,COLORGREEN,LINICK4;
    DRAWTEXT(H>MA(CLOSE,5)*1.07 AND ISLASTBAR AND 提示,H*1.01,'离!'),COLORGREEN,LINICK2;
    DRAWTEXT(L<MA(CLOSE,5)*1.005 AND L>MA(CLOSE,5) AND 提示=0 AND H<MA(CLOSE,5)*1.07 AND ISLASTBAR,L/1.02,'低吸'),COLORGREEN,LINICK2;
    {////MACD反身向上////}
    {MACD红缩:=REF(MACD,1)>MACD AND MACD>0;
    DRAWTEXT(REF(EVERY(MACD红缩,3),1)
    AND MACD>REF(MACD,1) AND C>MA(C,22) AND 提示=0,L/1.02,'启动'),COLORWHITE;
    }
    {////MACD反身向上2////}
    {MACD红缩2:=REF(MACD,1)>MACD AND MACD>0;
    DRAWTEXT(REF(EVERY(MACD红缩2,2),1)
    AND MACD>REF(MACD,1) AND C>MA(C,22) AND EVERY(DIFF>0,3) AND 提示=0,L/1.02,'起动'),COLORWHITE;
    }
    {突破买进(源码)}
    {DRAWTEXT(DYNAINFO(7)>0 AND ISLASTBAR ,HIGH,'("DYNAINFO(7)")');}
    上5日:=REF(EVERY(C<MA1,2),1) AND CROSS(C,MA1);
    STICKLINE(上5日,H,L,0,0),COLORFF00FF;
    {STICKLINE(上5日,O,C,2.7,0),COLOR3366FF;}
    STICKLINE(上5日,O,C,2.7,0),COLORFF00FF;
    DRAWICON(上5日,L,1);
    破5日:=REF(EVERY(C>MA1,4),1) AND CROSS(MA1,C);
    DRAWICON(破5日,H,2);
    DT:=REF(CLOSE/REF(C,1),1)<=0.95;
    DRAWTEXT(AA AND DT AND CURRBARSCOUNT<60 ,H,'急挖坑'),COLORGREEN;
    SC1:=MACD.MACD<0;
    SC2:=CROSS(十,五);
    SC3:=MA(V,5)<MA(V,10);
    SC:=SC1 AND SC2 AND SC3 ;
    DRAWTEXT(SC AND CURRBARSCOUNT<10 ,HHV(H,5),'三死叉'),COLORWHITE;
    JC1:=MACD.MACD>0;
    JC2:=CROSS(五,十);
    JC3:=MA(V,5)>MA(V,10);
    JC:=JC1 AND JC2 AND JC3 ;
    DRAWTEXT(JC AND CURRBARSCOUNT<20 ,LLV(L,5),'后金叉'),COLORYELLOW;
    {ZS:=CROSS(DMI.ADXR,DMI.ADX);
    DRAWTEXT(ZS AND CURRBARSCOUNT<10 ,HHV(H,5),'转势'),COLORRED;}
    {IF(五<REF(五,1),五,DRAWNULL),COLOR888888,LINICK1;};
    {XQK:=H<REF(L,1) ;
    DRAWTEXT(XQK AND CURRBARSCOUNT<20 ,H,'□□□□□□□□□□□□'),COLOR999999;
    SQK:= L>REF(H,1);
    DRAWTEXT(SQK AND CURRBARSCOUNT<20 ,L,'□□□□□□□□□□□□'),COLORRED;};
    DRAWTEXT(CROSS(H,离B) AND CURRBARSCOUNT<10 ,HHV(H,3),'超乖离'),COLORYELLOW;
    DRAWTEXT(CROSS(H,离A) AND CURRBARSCOUNT<10 ,HHV(H,3),'超乖离'),COLORYELLOW;
    DRAWTEXT(CROSS(离C,L) AND CURRBARSCOUNT<10 ,LLV(L,3),'负乖离'),COLORWHITE;
    DRAWTEXT((C<MA(C,5) OR MA(C,5)<MA(C,10)) AND CURRBARSCOUNT<2,HHV(H,5)*1.04,'MA5下'),COLORRED;
    DRAWTEXT((C<MA(C,5) OR MA(C,5)<MA(C,10)) AND CURRBARSCOUNT<2 ,HHV(H,5)*1.01,'不持股'),COLORRED;
    此公式已在通达信测试能过,请给个"满意答复"以后互相交流学习.

    Q2:求高手编写通达信三死叉预警选股公式。

    你要求的MACD死叉指的是MACD指标中的DIF和DEA死叉吗?

    Q3:三线金叉买入法是什么?

    不知道

    Q4:三金叉和三死叉的图是怎样的

    1,所谓三金叉见底,简而言之就是均线、均量线与MACD的黄金交叉点同时出现,股价在长期下跌后开始启稳筑底,而后股价缓慢上升,这时往往会出现5日与10日均线、5日与10日均量线以及MACD的黄金交叉点,这往往是股价见底回升的重要信号。
    2,所谓三死叉是指当股价长时间上涨后在顶部时,移动均线5日均线与10日均线形成由上向下的交叉,成交量5日均量线与10日均线形成的由上至下的交叉,MACD中DIF由上至下与DEA形成死亡交叉。当此形态出现时,我们要毫不犹豫的卖出,否则越套越深

    • 评论列表

    发表评论: